В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vartur203
Vartur203
19.01.2021 01:42 •  Информатика

Написать программу в pascal. старинная . сколько можно купить быков, коров и телят, если плата за быка 5 рублей, за корову - 3 рубля, за теленка - полтинник (0,5 рубля), если на 100 рублей надо купить 100 голов скота. плюс 1 , если алгоритм эффективный.

Ответ:
настя06032005
настя06032005
18.06.2020 13:29

program raf105;

const

s = 100;

var b,k,t: integer;

begin

writeln('Все возможные решения задачи:');

for b:=0 to (s div 5)+1 do

 for k:=0 to ((s - b*5) div 3)+1 do

 begin

   t := trunc( (s - b*5 - k*3) / 0.5 );

   if ((b+k+t) = 100) and ( (b*5+k*3+t*0.5)=s)

     then begin

       writeln;

       writeln('Быков: ',b);

       writeln('Коров: ',k);

       writeln('Телят: ',t);

     end;

 end;

end.

PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?