В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
marijamihaylow
marijamihaylow
14.07.2020 10:24 •  Информатика

Составить программу на pascal.
№1
даны 2 строки. необходимо вывести слово yes, если строки , и слово no в противном случае. (не использовать функцию compare).
№2
дан текст, состоящий из 1 слова. определить является ли оно палиндромом.
№3
дана строка. вывести те буквы, которые встречаются в строке ровно 2 раза.

Ответ:
anait87
anait87
21.01.2020 03:03

nomer3

program ab;

uses crt

uses sysutils;

var s,s1: string;

i,j: integer;

begin

clrscr;

write('введите строку слово');

writeln;

readln(s);

for i: =1 to length(s) do

for j: =1 to length(s) do

if (s[i]=s[j]) and(i< > j)

then

if pos(s[i], s1)=0

then s1: =s1+s[i]+' ';

write('повторяющиеся символы: ', s1);

readln;

end.

nomer2

program as

uses crt;

var s,sp: string;

i: integer;

begin

clrscr;

write('s=');

readln(s);

sp: ='';

for i: =1 to length(s) do

sp: =s[i]+sp;

if sp=s then writeln ('палиндром')

else writeln ('не палиндром');

readkey

end.

nomer1

function compare(s1,s2: string): boolean;

begin

result: =s1=s2;

end;

var s1,s2: string;

begin

readln(s1);

readln(s2);

if compare(s1,s2) then write('yes')

else write('no')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?