В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лала123451
лала123451
12.04.2022 06:48 •  Информатика

Надо написать программу в pascal которая скажет поместится прямоугольный шкаф с длиной с,шириной a и высотой b в круглую дверь с радиусом r?

Ответ:
dimaolegon96
dimaolegon96
27.08.2020 14:59

минимальный радиус двери в которую поместится шкаф равен радиусу описаной окружности вокруг прямоугольника равного размерам шкафа.

находим его по фрпмуле

R=\frac{\sqrt{a^{2}+b^{2}}}{2}

ну и пишем программу

var

   a, b : integer;

   r1, r2 : real;

begin

   writeln('введите:');

   write('высота шкафа a=');

   readln(a);

   write('ширина шкафа b=');

   readln(b);

   write('радиус двери R=');

   readln(r1);

   r2 := sqrt(sqr(a)+sqr(b))/2;

   if r1 >= r2 then writeln('шкаф пройдет') else writeln('шкаф не пройдет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?