В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Санжик707
Санжик707
05.09.2022 05:16 •  Информатика

Напишите программу, которая составит все возможные комбинации из цифр 3.4.5.6. и проверит каждую из этих комбинаций, является ли она точным квадратом

Ответ:
ulia09200413
ulia09200413
11.10.2020 00:03

Объяснение:

var a,b,c,d:integer;

begin

for a:=3 to 6 do

   for b:=3 to 6 do

       for c:=3 to 6 do

           for d:=3 to 6 do  begin

           if (a<>b) and (a<>c) and (a<>d)  and (b<>c) and (b<>d) and (c<>d)  and (frac(sqrt(1000*a+100*b+10*c+d))=0) then

writeln(a,b,c,d);

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?