В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дарья1644
дарья1644
13.06.2022 16:11 •  Информатика

Составить программу в c++ и по возможности блок-схему.
вот как выглядит программа в паскале
program z1;
var
q,x,y,z,a,b,c,d,e: integer;
w: real;
begin
writeln('введите x');
readln(x);
writeln('введите y');
readln(y);
writeln('введите z');
readln(z);
a: =x*y*z;
b: =3*z*x;
c: =2*(x+y+z);
d: =max(a,b);
e: =max(b,c);
q: =max(e,d);
writeln('максимум',q);
w: =min(3*x*y*z,q/2);
writeln('минимум',w);
end.

Ответ:
666Dim
666Dim
03.09.2020 10:52

Переделал программу с паскаля на С++

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

int main(){

srand(time(0));

system("chcp 1251 > nul");

int q,x,y,z,a,b,c,d,e;

double w;

cout << "Введите x: ";

cin >> x;

cout << "Введите y: ";

cin >> y;

cout << "Введите z: ";

cin >> z;

a = x*y*z;

b = 3*z*x;

c = 2*(x+y+z);

d = max(a,b);

e = max(b,c);

q = max(e,d);

cout << "Максимум: " << q<< endl;

w = min((3*x*y*z),(q/2));

cout << "Максимум: " << w << endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?