В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
исл5
исл5
02.06.2020 13:26 •  Информатика

Написать программу нахождения количества элементов, меньших 13 и кратных 8 массива а[8] заполненного случайными числами [-50,25)​

Ответ:
Anton222666222
Anton222666222
10.10.2020 18:59

var a:array [1..10] of integer;

i,j:integer;

begin

 for i:=1 to 10 do a[i]:=random(-50,25);

 writeln ('Массив:');

 writeln (a);

 writeln ('Числа меньше 13 и кратные a[8]:');

 for i:=1 to 10 do

 if (a[i]<13) and (abs(a[i]) mod abs(a[8])=0 ) then write (a[i],' ');

end.

0,0(0 оценок)
Ответ:
ayunatushentso
ayunatushentso
10.10.2020 18:59

var i,k:integer;

a:array [1..8] of integer;

begin

write('Массив');

for i:=1 to 8 do

begin

a[i]:=random (75)-50;

write(a[i]:4);

if (a[i]<13) and (a[i] mod 8 = 0 ) then k:=k+1

end;

writeln;

writeln('Количество элементов, меньших 13 и кратных 8 равно ',k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?