Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Vasyliev
26.08.2022 06:18 •
Информатика
Написать программу вычисления выражения (5а-3)(4-3b)+c
в паскале
Ответ:
samigyllin
10.10.2020 15:57
Var a, b, c: integer;
begin
readln (a, b, c);
writeln ((5*a-3) * (4-3*b) + c);
end.
Поясняю за код:
Первой строкой задаём переменные (аbc) и обозначаем их тип (здесь: integer - целые числа, при необходимости - замени на числа с плавающей точкой);
Второя строчка - для красоты, необязательна;
Третья - начало программы;
Четвертая - считывает с клавиатуры переменные аbc;
Пятая - выводим на экран результат выражения,
Шестая строка - конец.
---Так же можно было задать новую переменную d (что бессмысленно, но, наверное, пока именно этот вариант тебе подойдёт)
var a, b, c, d: integer;
begin
readln (a, b, c);
d:=((5*a-3) * (4-3*b) + c);
writeln(d)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ШкОлА1337228
09.01.2023 00:41
Назовите устройства ввода информации...
PolinaMm
14.08.2020 15:53
Напишите рекурсивную функцию, печатающую все неотрицательные элементы массива в обратном порядке...
SnopcovaAlina07
26.09.2020 23:52
Дано натуральное число составить программу которая определяет сумму кубов его цифр с++...
kirillmotoin
23.04.2021 12:45
Написать программу, выводящую на экран четные двухзначные числа от 25 до 85, сумма цифр входящих, в состав которых равна 7. На Паскале...
Dima1208
05.10.2022 17:41
Дан одномерный массив целых чисел a(n) написать процедуру нахождения максимального числа...
Balabol2010
04.02.2021 14:38
Составте блок схему вычисления значения функции: {2x+1, если x 1 y= { {3x-1, если x =1...
111mart111
14.02.2023 14:44
Эти слова не правильно написана как правильно 1)ghtir 2)ghsartit 3)pu 4)wodn 5)dnuora 6)otin...
katabelja
14.02.2023 14:44
Развёрнутый план ответа по теме: развитие промышленности сельского хозяйства и торговля россии во второй половине 18 века...
EveChan
14.02.2023 14:44
Напишите сочинение на тему концерт на...
мммммммммм12
14.02.2023 14:44
Вычислить площадь круга, радиус которого 8 см...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln (a, b, c);
writeln ((5*a-3) * (4-3*b) + c);
end.
Поясняю за код:
Первой строкой задаём переменные (аbc) и обозначаем их тип (здесь: integer - целые числа, при необходимости - замени на числа с плавающей точкой);
Второя строчка - для красоты, необязательна;
Третья - начало программы;
Четвертая - считывает с клавиатуры переменные аbc;
Пятая - выводим на экран результат выражения,
Шестая строка - конец.
---Так же можно было задать новую переменную d (что бессмысленно, но, наверное, пока именно этот вариант тебе подойдёт)
var a, b, c, d: integer;
begin
readln (a, b, c);
d:=((5*a-3) * (4-3*b) + c);
writeln(d)
end.