В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
соня7871
соня7871
17.09.2020 13:59 •  Информатика

Напишите программу, которая получает число из данного файла, делит его на 3 и записывает ответ в другой файл

Ответ:
MorEnSo
MorEnSo
10.10.2020 13:33

Программа на языке Pascal. Программа получает число из файла input.txt и записывает результат в файл output.txt

var a: real;

f: text;

begin

assign(f,'input.txt');

reset(f);

read(f,a);

close(f);

assign(f,'output.txt');

rewrite(f);

write(f,a/3);

close(f);

end.

0,0(0 оценок)
Ответ:
soniy135
soniy135
10.10.2020 13:33

PascalABC.NET

begin

 WriteAllText('File2.txt',

   (integer.Parse(ReadAllText('File1.txt')) div 3).ToString)

end.

Объяснение:

Текстовый файл File1.txt содержит запись целого числа.

ReadAllText('File1.txt') считывает сдержимое файла в символьную строку,

integer.Parse( ) выделяет из нее целое целое число, div 3 выполняет деление на 3, результат при преобразуется к строке, на основе которой WriteAllText('File2.txt'( ) создает текстовый файл File2.txt.

Файлы должны находиться в той же папке, что и исходный текст программы, либо надо в именах явно указывать полный путь.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?