В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ЮлиLove
ЮлиLove
11.06.2020 23:43 •  Информатика

Площадь треугольника 2
Напишите программу, которая вычисляет площадь треугольника, если даны только две стороны треугольника, и угол между данными сторонами.

Вводные данные: на первой строке число N, количество треугольников. Затем на N строках, 3 числа: первые две стороны треугольника, а последнее число угол между этими сторонами со значением в градусах.

Выходные данные: для каждого треугольника на N строках значение площади, которое округлено до 5 знака после точки. Используйте функцию для вычисления площади для каждого треугольника.
Ввод:
4
13 15 30
12 16 48
16 18 9
14 16 111

Вывод должен быть таким:
48.75
71.3419
22.52656
104.56101

Ответ:
Mari666a
Mari666a
11.10.2020 11:41

from math import sin, radians

n = int(input())

output = []

for i in range(n):

   x = [int(k) for k in input().split()]

   output.append(round(0.5*x[0]*x[1]*sin(radians(x[2])), 5))

for i in output:

   print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?