В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sonya2896
Sonya2896
31.08.2021 05:04 •  Информатика

Написать программу (с использованием процедур и функций) ​

Ответ:
talipovskiyt
talipovskiyt
10.10.2020 11:31

procedure FormMas(a: array[,] of integer; var v: array of int64);

var

 m, n, i, j, k: integer;

begin

 m := length(a, 0);

 n := length(a, 1);

 setlength(v, n);

 for j := 0 to n - 1 do

 begin

   v[j] := 1;

   k := 0;

   for i := 0 to m - 1 do

     if a[i, j] < 0 then

     begin

       k := k + 1;

       v[j] := v[j] * a[i, j]

     end;

   if k = 0 then

     v[j] := 0;

 end;

end;

function KolNul(a: array[,] of integer): integer;

var

 m, n, i, j, k, p: integer;

begin

 k := 0;

 m := length(a, 0);

 n := length(a, 1);

 for j := 0 to n - 1 do

 begin

   p := 0;

   for i := 0 to m - 1 do

     if a[i, j] < 0 then

       p := p + 1;

   if p = 0 then

     k := k + 1;

 end;

 KolNul := k;

end;

var

 m, n, i, j, k: integer;

 a: array[,] of integer;

 b: array of int64;

begin

 read(m, n);

 setlength(a, m, n);

 for i := 0 to m - 1 do

   for j := 0 to n - 1 do

     read(a[i, j]);

 FormMas(a, b);

 for j := 0 to n - 1 do

   write(b[j], ' ');

 writeln;

 k := KolNul(a);

 write(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?