В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KarinaZinovets
KarinaZinovets
21.04.2022 05:41 •  Информатика

Написать программу (паскаль)
в массиве хранится информация о стоимости 1 кг 20 видов конфет. определить, сколько стоят самые дешёвые конфеты . если таких несколько, то должен быть найден индекс первого из них .

Ответ:
Vadim43k
Vadim43k
05.08.2020 09:23

program test;

var a:array [1..20] of integer;

min, i, imin: integer;

begin

min:=a[19];

imin:=19;

for i:=1 to 20 do begin

a[i]:=random (151)+150;

write (a[i]:4);

end;

writeln;

for i:=19 downto 1 do begin

if a[i]<min then begin imin:=i; min:=a[i]; end;

end;

write (imin);

writeln;

write (a[imin]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?