В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
irko00
irko00
28.06.2021 03:18 •  Информатика

Как написать программу в pascal в строчку, которая выводит разряды числа 12321? )

Ответ:
marsik12912
marsik12912
10.10.2020 06:42

program Example2;

var

 a, i: Integer;

begin

 Write ('Введете целое число: ');

 ReadLn (a);

 WriteLn;

 Write ('Разряды числа: ');

 while a > 0 do begin

   Write (a mod 10, ' ');

   a := a div 10;

 end;

 ReadLn;

end.

Объяснение:

mod -  выделяем последнюю цифру

div - отбрасываем последнюю цифру

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?