В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
manyaovakimyan
manyaovakimyan
27.11.2022 17:11 •  Математика

Информатика 9 класс 3. составить программу планирования закупки товара в магазине на сумму, не превышающую заданную величину. обозначим через x,k-соответствующую цену и количество товара, а через p-заданную предельную сумму, через s- общую стоимость покупки. значение предельной суммы считывается с клавиатуры. необходимо повторять запрос цены и количества выбранного товара, вычислять его стоимость, суммировать ее с общей стоимостью и выводить результат на экран до тех пор, пока она не превысит предельную сумму p.

Ответ:
kotovaann2016
kotovaann2016
17.08.2020 08:49

program Goods;


var x,k,p,s: word;


begin

writeln('Введите предельную сумму:');

readln(p);

s:=0;


while s<=p do

begin

writeln('Введите стоимость вещи:');

readln(x);

writeln('Введите количество:');

readln(k);

s:=s+x*k;

writeln('Сумма затрат:', s);

writeln('Предел суммы:', p)

end;


writeln('Вы превысили сумму покупок')


end.

0,0(0 оценок)
Популярные вопросы: Математика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?