В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Арсенал11
Арсенал11
06.01.2022 17:22 •  Информатика

Напишите программу которая находит и выводит на экран 4 максимальных элемента последовательности числа которой различны. язык паскаль

Ответ:
zaxar3512
zaxar3512
06.08.2020 10:23

type z=array of integer;

var a: z;

i,j,k: integer;

begin

setlength(a,1);

readln(a[0]);

i:=1;  

while(a[i-1]<>0) do

begin

setlength(a,i+1);

readln(a[i]);

i:=i+1;

end;

setlength(a,length(a)-1);

for i:=0 to length(a) do

for j:=0 to length(a)-2 do

if (a[j] < a[j+1]) then

begin

k:=a[j];

a[j]:= a[j+1];

a[j+1]:=k;

end;

write(a[0],'; ',a[1],'; ',a[2],'; ',a[3]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?