В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Anymarspop
Anymarspop
26.11.2020 17:08 •  Информатика

Python 3.7
напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводятся количество чисел (0 не считаем), минимальное и максимальное из введенных чисел, их сумму и среднее значение.
заранее большое

Ответ:
Ананасик2052
Ананасик2052
10.10.2020 06:09

{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}

var

min,max,a:real;

begin

  readln(a);

  min:=a;max:=a;

   while a<>0 do

       begin

            readln(a);

                if a>max then

                    max:=a;

                if a<min then

                     min:=a;

        end;

writeln('min: ',min,'  max: ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?