В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Danika38
Danika38
15.03.2020 15:23 •  Информатика

Напишите программу на с++, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 9. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода,
не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел, кратных 3 и оканчивающихся на 9.

Ответ:
анна2216
анна2216
10.10.2020 05:13

#include <iostream>

using namespace std;

int main()

{

int a,S=0;

cin >> a;

while(a!=0)

{

if(a % 3 == 0 && a % 10 == 9) S=S+a;

cin >> a;

}

cout<<S;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?