В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
seniorkovalyov
seniorkovalyov
03.03.2023 09:52 •  Информатика

Необходимо составить программу, для вычисления по формуле: у=7-2*x, если x< 0; y=x-1 если x=0; y=(x+4)*2 если x> 0язык с++30 !

Ответ:
goldlena1979
goldlena1979
11.09.2020 09:54

#include <iostream>

using namespace std;

int main() {

int x;

cin >> x;

if (x < 0) {

 cout << "y=" << 7 - 2 * x << endl;

} else if (x == 0) {

 cout << "y=" << x - 1 << endl;

} else {

 cout << "y=" << (x + 4) * 2 << endl;

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?