В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Б45
Б45
22.02.2021 03:57 •  Информатика

Pascal abc. напишите программу! "дан массив размера n. вывести последний нечетный элемент массива и его номер"

Ответ:
Katyha028272819
Katyha028272819
22.01.2024 10:03
Хорошо, давайте решим задачу по написанию программы на языке Pascal.

Для начала, нам понадобится задать массив и его размерность. Давайте создадим переменные для этого:

var
n, i, lastOdd, lastOddIndex: integer;
arr: array[1..100] of integer;

Здесь:
- n - переменная для хранения размерности массива, то есть количество элементов
- i - переменная для использования в цикле
- lastOdd - переменная для хранения значения последнего нечетного элемента
- lastOddIndex - переменная для хранения индекса последнего нечетного элемента
- arr - массив, в котором будем хранить элементы

Следующим шагом, нам нужно предложить пользователю ввести размерность массива и его элементы. Для этого используем следующий код:

writeln("Введите количество элементов в массиве:");
readln(n);
writeln("Введите элементы массива:");

for i := 1 to n do
begin
readln(arr[i]);
end;

Теперь у нас есть массив arr с заданной размерностью n и введенными элементами.

Далее, мы проходим по массиву в обратном порядке и ищем последний нечетный элемент:

lastOdd := -1; // Инициализируем переменную последнего нечетного элемента значением -1 (это значение будет оставаться таким, если в массиве не будет нечетных элементов)

for i := n downto 1 do
begin
if arr[i] mod 2 <> 0 then // Проверяем, является ли текущий элемент нечетным
begin
lastOdd := arr[i]; // Присваиваем значение текущего элемента последнему нечетному
lastOddIndex := i; // Запоминаем индекс последнего нечетного элемента
Break; // Прерываем цикл, так как мы уже нашли последний нечетный элемент
end;
end;

Наконец, выводим результат на экран:

writeln("Последний нечетный элемент:", lastOdd);
writeln("Его номер:", lastOddIndex);

Вот и всё! Мы написали программу на языке Pascal, которая находит последний нечетный элемент массива и выводит его значение и индекс на экран.

Если у вас возникнут вопросы, не стесняйтесь задавать. Я готов помочь вам понять решение еще лучше!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?