В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
nickieivanov
nickieivanov
15.08.2020 23:07 •  Информатика

Решить: напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 ( 0- признак окончания ввода не входит в
последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел кратных 5 или 9. ​

Ответ:
Mondy228
Mondy228
10.10.2020 03:05

я вроде уже решал такую задачу... Ту в условиях только добавилась фраза "по модулю". Скорректировал программу с учетом уточнения в задании.

var

   a, n, i : integer;

begin

   repeat

       read(a);

       if (abs(a) <= 30000) and (a <> 0) then begin

           if (a mod 5 = 0) or (a mod 9 = 0) then n += 1;

           i += 1;

       end;

   until (a = 0) or (i = 1000);

   writeln(n);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?