В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
2003stanislav
2003stanislav
30.05.2021 02:41 •  Информатика

Программисты !
(program pr1) ! паскаль.

составить программу: данно трехзначное число (например 4 5 6). получить число, в котором цифры стоят в обратном порядке (6 5 4) ​​

Ответ:
Алентина
Алентина
11.08.2020 15:21

uses

 Math;

var

 n, r, i, d: Integer;

begin

 Write ('Введите трехзначное число: ');

 ReadLn (n);

 r := 0;

 d := 100;

 if (n >= 100) and (n <= 999) then begin

   for i := 1 to 3 do begin

     r := r + (n mod 10) * d;

     n := n div 10;

     d := d div 10;

   end;

   WriteLn ('Результат = ', r);

 end else

   WriteLn ('Это не трехзначное число');

 ReadLn;

end.

Объяснение:

для 3 цифр в цикле выделяются единицы, десятки, сотни.

умножается на d: в цикле меняется 100, 10, 1

результат суммируется в r

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?