В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу, еоторая заполняет массив из 10 элементов случайными числами на отрезке [ -5; 5] и находит сумму ненулевых элементов. в системе паскаль. никак не могу составить, , .

Ответ:
edelbi9512
edelbi9512
25.01.2024 05:46
Конечно, я помогу тебе с заданием!

Вот пошаговое решение этой задачи на языке Паскаль:

1. Создадим переменную sum, которая будет хранить сумму ненулевых элементов массива.
```pascal
var
sum: integer;
```

2. Создадим массив из 10 элементов.
```pascal
var
arr: array[1..10] of integer;
```

3. Импортируем модуль для работы с генерацией случайных чисел.
```pascal
uses
Crt;
```

4. С помощью цикла for заполним массив случайными числами и найдем сумму ненулевых элементов.
```pascal
begin
randomize; // Инициализация генератора случайных чисел

sum := 0; // Инициализация суммы

for var i := 1 to 10 do // Цикл для заполнения массива и поиска суммы
begin
arr[i] := random(11) - 5; // Генерация случайного числа от -5 до 5
if arr[i] <> 0 then // Если элемент не равен нулю
sum := sum + arr[i]; // Увеличиваем сумму на значение элемента
end;
end.
```

5. Выведем на экран массив и сумму ненулевых элементов.
```pascal
writeln('Массив:');
for var i := 1 to 10 do
write(arr[i], ' ');
writeln;

writeln('Сумма ненулевых элементов:', sum);
```

Теперь у тебя есть полная программа на языке Паскаль, которая решает задачу. Программа генерирует массив из 10 элементов случайными числами в диапазоне [-5; 5] и находит сумму ненулевых элементов. После запуска программы на экран будет выведен массив и сумма ненулевых элементов.

Удачи с выполнением задания! Если есть дополнительные вопросы, не стесняйся задавать!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?