В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
angelina453
angelina453
15.09.2022 06:32 •  Информатика

Дано натуральное число n, вычислить n! (0! =1, n! =n*(n- составить программу на pascal.

Ответ:
korolovk
korolovk
10.10.2020 01:58

var

   a : integer;

   fac : BigInteger := 1;

   

begin

   readln(a);

   if a > 0 then for var i := 1 to a do fac *= i;

   writeln(a, '!=', fac);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?