В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mariainbox303
mariainbox303
12.11.2021 02:13 •  Информатика

Напишите программу вычисления выражения: s=1! +2! +3! ++n! здесь n! - факториал числа n. n! =1×2××(n-1)× n.используйте функцию вычисления факториала..​

Ответ:
AmoskovaAlenka
AmoskovaAlenka
10.10.2020 01:12

var

   n : integer;

   S : decimal;

   

function fac(n : integer) : decimal;

begin

   result := 1;

   for var i := 1 to n do result := result * i;

end;


begin

   write('введите n = ');

   readln(n);

   for var i := 1 to n do S := S+fac(i);

   writeln('S=', S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?