В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
adashevanastya
adashevanastya
04.05.2023 12:24 •  Информатика

Напишите программу,которая для последовательности натуральных чисел выводит сумму всех входящих в последовательность чисел,кратных 3 и при этом меньших 150.программа получает на вход количество чисел в последовательности,а затем сами числа. количество чисел не превышает 100.введённые числа не превышают 300. программа должна вывести одно число-сумму вех входящих в последовательность чисел,кратных 3 и при этом меньших 150. входные данные: 3 33 6 270 выходные данные 42

Ответ:
tbzhi
tbzhi
17.08.2020 09:36

var a,i,k,sum:integer;

begin

read(a);

for i:=1 to a do begin

read(k);

if(k mod 3 =0)and(k<150)then sum:=sum+k;

end;

write(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?