В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
iirunka153
iirunka153
25.08.2021 17:19 •  Информатика

Составить программу к : сколько шансов при бросании трёх игральных костей выбросить x очков (от 3 до 18) и какие это варианты ( при вложенный циклов). pascal abc

Ответ:
луч16
луч16
10.10.2020 00:33

var pk,vk,tk,x,k:integer;

begin

write('x = ');

readln(x);

for pk:= 1 to 6 do

begin

for vk:=1 to 6 do

begin

for tk:=1 to 6 do  

if pk+vk+tk=x then

begin

writeln('pk = ',pk,'   vk = ',vk,'   tk = ',tk,'   ',pk,' + ',vk,' + ',tk,' = ',pk+vk+tk);

k:=k+1

end

end

end;

writeln(k,' шансов')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?