В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
msakinat
msakinat
07.12.2022 06:59 •  Информатика

На вход программе подается количество битов.составьте программу ,которая переводит биты в байты ,килобайты,мегабайты,гигабайты.заранее ! )

Ответ:
pavel271
pavel271
27.08.2020 14:07
Program bity;
var a, b, c, d, e: real;
begin
write ('Введите количество бит: ');
read (a);
b:=a/8;
c:=b/1024;
d:=c/1024;
e:=d/1024;
writeln ('Это столько байт: ', b:8:4);
writeln ('Это столько килобайт: ', c:8:4);
writeln ('Это столько мегабайт: ', d:8:4);
write ('Это столько гигабайт: ', e:8:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?