В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ianastepanenko
ianastepanenko
05.11.2021 00:00 •  Информатика

Составить программу,определяющую сумму положительных элементов одномерного массива b,состоящего из 14 вещественных значений

Ответ:
ммаа2
ммаа2
09.10.2020 23:16

var

 B: array [1..14] of Real;

 i: Integer;

 s: Real;

begin

 Randomize;

 WriteLn ('Mассив:');

 for i := Low (B) to High (B) do begin

   B [i] := Random (100) - 50;

   Write (B [i]:5:2, ' ');

 end;

 s := 0;

 for i := Low (B) to High (B) do begin

   if B [i] > 0 then

     s := s + B [i];

 end;

 WriteLn;

 WriteLn ('Сумма положительных элементов массива = ', s:5:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?