В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
juliana123456
juliana123456
01.05.2022 22:59 •  Информатика

Составить программу на паскале: заполнить массив вм случайными числами из диапазона от 1 до 150. размерность массива 20.распечатать массив на экране в строку. найти сумму всех нечётных чисел массива. результат вывести на экран в отдельной строке.

Ответ:
Marinap041744
Marinap041744
09.10.2020 23:10
program n_1; const  n = 20; var  a: array [1..n] of integer;  i, sum: integer; begin  sum := 0;  for i := 1 to n do    begin    a[i] := random(150) + 1;    write('a[', i, '] = ', a[i], '; ');    if odd(a[i]) then inc(sum, a[i]);    end;  writeln ();  write('sum = ', sum); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?