В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
katyaivanova17
katyaivanova17
16.12.2022 05:04 •  Информатика

Написать программу в паскале массив 5х3 заполнить случайными числами [0; 100]. в каждой строке поменять местами максимальное и минимальное число.

Ответ:
KseniyaTyan2018
KseniyaTyan2018
09.10.2020 23:00

const g = 5; v = 3;

var a: array[1..g,1..v] of integer;

i,j,maxj,minj,p:integer;

begin

writeln('Массив: ');

for i:=1 to g do

begin

for j:=1 to v do

begin

a[i,j]:=Random(101);

write(a[i,j]:4)

end;

writeln

end;

for i:=1 to g do

begin

maxj:=1;

minj:=1;

for j:=1 to v do

begin

if a[i,j]>a[i,maxj] then maxj:=j;

if a[i,j]<a[i,minj]then minj:=j;

end;

p:=a[i,maxj];

a[i,maxj]:=a[i,minj];

a[i,minj]:=p;

end;

writeln;

writeln('Преобразованный массив: ');

for i:=1 to g do

begin

for j:=1 to v do write(a[i,j]:4);

writeln

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?