В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
oksaniana
oksaniana
23.05.2020 03:56 •  Информатика

Заполнить двумерный массив f размером x*y целыми случайными числами из промежутка [-130; 130] и вывести этот массив на экран. определить количество чисел некратных 5 в заданном массиве. расписать этапы. составить блок-схему. выполнить трассировку всех этапов для массива размером 2*3. написать программу.

Ответ:
nataliastatinap0147d
nataliastatinap0147d
09.10.2020 22:38

program massive;

const

x=2;

y=3;

var  

 f: array [1..x,1..y] of integer;

 i,j,s:integer;

begin

 randomize;

 s:=0;

 for i:=1 to x do

   begin

     for j:=1 to y do

       begin

         f[i,j]:=random(-130,130);

         write(f[i,j],' ');

       end;

     writeln;

   end;

 for i:=1 to x do

   for j:=1 to y do

     if f[i,j] mod 5 <> 0 then  

       s:=s+1;

 if s=0 then  

   writeln('Все элементы fкратны 5')

 else  

   writeln('Элементов не кратных 5: ',s);

end.

1) Заполняем массив случайными элементами

2) Проверяем каждый элемент на кратность  5

3) И считаем их количество


Заполнить двумерный массив f размером x*y целыми случайными числами из промежутка [-130; 130] и выве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?