В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vgorelova62
vgorelova62
03.10.2021 17:27 •  Информатика

Написать программу в си, которая переворачивает массив. (пример: 12345 ⇒ 54321)

Ответ:
mashuljka33
mashuljka33
09.10.2020 21:30

#include "stdio.h"

#include "stdlib.h"

int main(){

int amount = 0;

int mas[amount];

int temp;

printf("Input capacity of massiv: "); scanf("%d",&amount);

for(int i = 0 ; i < amount; ++i){

 printf("Element [%d] = ",i+1); scanf("%d",&mas[i]);

}

for(int i = 0; i < amount/2; ++i){

 temp = mas[amount-i-1];

 mas[amount-i-1] = mas[i];

 mas[i] = temp;

}

for(int i = 0; i < amount; ++i){

 printf("%d ", mas[i]);

}

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?