В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Уровень b. напишите программу, которая заполняет массив из n = 10 элементов случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу x. программа должна вывести ответ «не найден», если в массиве таких элементов нет.пример: массив: -5 -6 2 3 -3 0 8 -3 0 9что ищем: 0a[9] = 0на паскале(старая версия)

Ответ:
zangeevdima
zangeevdima
09.10.2020 21:27

Примерно так:

program Poisk;

const

N = 10;

type

mas = array [-10..N] of integer;

var

a: mas;

x: integer;

i: integer;

begin

readln (x);

for i := 1 to x do

a[i] := random (10);

for i := 1 to x do

begin

if (a[i] = 0) then

writeln ('a',i,' := ',a[i])

else

writeln ('Такого индекса нету');

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?