В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
228Cracker228
228Cracker228
26.11.2021 23:11 •  Информатика

Напишите программу которая будет искать в массиве два числа и считать их произведения

Ответ:
прииииииип
прииииииип
09.10.2020 21:19

var  

a: array[1..100] of integer;  

n, i: byte;  

sum, p: integer;

begin  

Randomize;  

readln(n);  

sum:=0; p:=1;  

for i:=1 to n do    

begin      

a[i]:=Random(101)-50;      

write(a[i]:4);      

sum:=sum+a[i];      

p:=p*a[i];    

end;  

writeln;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);  

sum:=0; p:=1;  

writeln('');  

writeln('2. С клавиатуры');  

for i:=1 to n do    

begin    

write('Элемент ', i, ' = ');    

readln(a[i]);    

sum:=sum+a[i];    

p:=p*a[i];    

end;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);

end.


Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?