В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BotanikAziz
BotanikAziz
14.01.2022 17:36 •  Информатика

Составить программу к следующей . задан случайным образом одномерный массив из n действительных чисел в диапазоне от -10 до 50. подсчитать сколько в нем элементов больше (10).

Ответ:
pd101
pd101
09.10.2020 20:29

Код будет работать в Pascal ABC

(в остальных программах нужно поменять функцию рандома чисел)


program p1;

var  

  //Пусть массив будет состоять из 50 элементов

  n:array[1..50] of integer;

  i, j, s:integer;

begin

   

  //Создание массива случайный чисел от -10 до 50

  for i:= 1 to 50 do

    begin

       n[i]:= random(-10, 50);

       writeln(n[i]);

    end;

     

     //Подсчет  

     for j:= 1 to 50 do

       begin

          if n[j] > 10 then

            begin

              s:=s+1;

            end;

       end;

     

    WriteLn('Элементов больше 10: ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?