В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dima22022005
Dima22022005
02.05.2022 12:57 •  Информатика

1. напишите программу которая даст 12 слагаемых чисел из [-35..35] и вычислить их сумму. 2. напишите программу, которая вычислить в байтах длину введённого текста. , ! паскаль

Ответ:
mari523
mari523
09.10.2020 20:24

Первая программа

var number, i, summa: integer;

begin

summa := 0;

randomize;

 for i := 0 to 12 do begin

   number := random(-35,35);

   writeln(number);

   summa := summa + number;

 end;

writeln(summa);

end.


Вторая программа

var text:string;

   i, len:integer;

begin

len := 0;

 readln(text);

 for i := 0 to length(text)-1 do begin

   len := len + 1;

 end;

 writeln(len*SizeOf(string));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?