В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
manfork
manfork
20.10.2022 03:14 •  Информатика

Паскаль /! напишите программу которая заполняет массив из n=8 элементов случайными числами в диапазоне [0,20] , выводит его на экран, а затем меняет местами пары соеденёных элементов, кроме первого и последнего(2 с 3, 4с 5 и т. пример: массив : 5 16 2 13 3 14 18 17 реверс: 5 2 16 3 13 18 14 17

Ответ:
Лол11лол
Лол11лол
11.09.2020 06:58

var

 a: array[1..10] of integer;

 i, n: integer;

begin

 n := 8;

 randomize;

 for i := 1 to N do

 begin

   a[i] := random(21);

   Write(a[i]:4);

 end;

 

 i := 2;

 while i <= N - 2 do

 begin

   Swap(a[i], a[i + 1]);

   i += 2

 end;

 

 Writeln;

 for i := 1 to N do

   Write(a[i]:4)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?