В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
8алина82
8алина82
31.12.2021 12:25 •  Информатика

Pascal. составить программу нахождения произведения всех элементов массива a[1..20], содержащего случайные числа от 1 до 10

Ответ:
inessa2012
inessa2012
09.10.2020 20:14

//fpc

const

MAX = 20;

var

A: array [1 .. MAX] of byte;

i: byte;

mult: extended;

BEGIN

randomize;

mult := 1;

for i := 1 to MAX do

begin

A[i] := random(10) + 1;

mult := mult * A[i];

end;

write('Произведение эл. массива = ');

writeln(mult:0:0);

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?