В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lehasokol03
lehasokol03
01.12.2020 15:14 •  Информатика

Дан одномерный массив .написать программу ,которая будет определять ,сколько раз первый элемент встречается в данном массиве на нечётных местах напишите на языке паскаль

Ответ:
Lopidon11
Lopidon11
09.10.2020 19:59

const n=15;

var a:array [1..n] of integer;

i,k:integer;

begin

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random(6);

write(a[i]:3,' ')

end;

for i:=2 to n do

if (a[1]=a[i]) and (i mod 2 <> 0) then k:=k+1;

writeln;

write('Первый элемент встречается в данном массиве на нечётных местах ',k,' раз')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?