В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
NikoYuqa1
NikoYuqa1
27.12.2020 01:25 •  Информатика

Написать программу в паскале, тема массивы возвести в квадрат элементы, не превосходящие по модулю введенное с клавиатуры число r.

Ответ:
epstalmakov
epstalmakov
09.10.2020 19:42

const n=10;

var a:array[1..n] of integer;

i,r: integer;

begin

write (' Исходный массив: ');

for i:=1 to n do

begin

a[i]:=random(41)-20;

write (a[i]:3,' ')

end;

writeln;

write ('Введите число: ');

readln (r);

write ('Преобразованый массив: ');

for i:=1 to n do

begin

if abs(a[i]) <= r then a[i]:=a[i]*a[i];

write (a[i]:3,' ')

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?