В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VasyaRaglinskiy66
VasyaRaglinskiy66
09.08.2022 19:40 •  Информатика

Задано целое число n написать программу которая находит количество 0 в заданном числе

Ответ:
Danil545849
Danil545849
09.10.2020 19:37

//PascalABC.NET v3.3 1633

begin

 var num:=ReadInteger('Введите число: ');

 var sum:=0;

 for var i:=1 to IntToStr(num).Length do

   if IntToStr(num)[i] = '0' then sum += 1;

 writeln('Количество нулей: '+sum);

end.

0,0(0 оценок)
Ответ:
DoraDreamer
DoraDreamer
09.10.2020 19:37
Java:

Scanner in = new Scanner();
String data = in.nextLine();
int counter =0;
for(char g:data.toCharArray()){
if('0'.equals(g)){
counter++;
}
}
System.out.println(counter);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?