В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
222812
222812
21.03.2023 08:02 •  Информатика

Заданы 5 чисел напишите программу которая выведет их в обратном порядке при этом переставив все цифры в каждом числе в обратном порядке

Ответ:
cea2
cea2
09.10.2020 19:38

const N=5;

var a:array [1..N] of integer;

i:integer;

s:string;

BEGIN

for i:=1 to N do

read(a[i]);

s:='';

for i:=N downto 1 do begin

while a[i]>0 do begin

s:=s+a[i] mod 10;

a[i]:=a[i] div 10;

end;

write(s,' ');

s:='';

end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?