В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
superogurec002
superogurec002
06.03.2021 18:33 •  Информатика

Напишите программу. дан массив действительных чисел размерности n. получить удвоенную сумму всех положительных элементов массива и удвоенное произведение всех отрицательных элементов массива, расположенных после максимального члена последовательности.

Ответ:
konfetkaa2004
konfetkaa2004
17.08.2020 07:51

const n=10;

var a:array [1..n] of real;

i,mi:integer;

s,m,p:real;

begin

write('Массив: ');

for i:=1 to n do

begin

a[i]:=random*20-10;

write(a[i]:0:3,' ');

if a[i]>0 then s:=s+2*a[i];

end;

writeln;

m:=a[1];

mi:=1;

for i:=1 to n do  if a[i]>m then

begin

m:=a[i];

mi:=i

end;

p:=1;

for i:=mi to n do  if a[i]<0 then p:=p*2*a[i];

writeln ('Удвоенная сумма всех положительных элементов массива: ',s:0:3);

if p=1 then writeln ('Отрицательных чисел после максимального элемента нет')

else writeln ('Удвоенное произведение всех отрицательных элементов массива, расположенных после максимального элемента: ',p:0:3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?