В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
умный2006
умный2006
09.04.2020 06:32 •  Информатика

Составьте программу которая формирует массив из 8 целых чисел [0,10] и выводит элементы массива в строку. затем находит произведение нечётных элементов и выводит результат

Ответ:
sashadorosh1953
sashadorosh1953
04.10.2019 07:01

program fantscrin;

  const n = 8;

  var a: array [1..n] of integer;

      i,s: integer;

begin

  for i: =1 to n do

    a[i]: = random(11)+1;

  for i: =1 to n do

    write(a[i], '   ');

  p: =1;

  for i: =1 to n do

    if (i mod 2 < > 0) then p: =p*a[i];  

  writeln('');

  writeln('произведение = ',p);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?