В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на c# "произвести суммирование натуральных чисел 1, 2, пока их сумма s не станет равной или превысит величину h. вывести на экран последнее слагаемое и значение суммы."

Ответ:
машазайка1
машазайка1
02.09.2020 17:02

Написал на c++ т,к синтаксис шарпа не знаю, можешь переделать под себя.

#include "pch.h"

#include <iostream>

using namespace std;



int main()

{

setlocale(LC_ALL, "rus");

int summa = 0;

int h;

int i = 1;

cout << "Введите h" << endl;

cin >> h;

for(i;summa<h;)

{

 summa += i;

 i++;

}

cout <<"Сумма= "<< summa << endl <<"Последнее слагаемое = "<< i - 1 << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?