В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anna5453p08o22
anna5453p08o22
10.03.2022 03:47 •  Информатика

Составьте программу, которая все числа кратные 10 делит на 10 а остальные умножает на 10. ввод элементов массива либо с клавиатуры, либо случайным образом. количество элементов массива задайте самостоятельно. побыстрее

Ответ:
f123123
f123123
09.10.2020 15:09

const n=10;

var i:integer;

a:array[1..n] of integer;

begin

for i:=1 to n do

begin

a[i]:=random(100);

write(a[i]:3,' ');

if a[i] mod 10 = 0 then a[i]:=a[i] div 10

else a[i]:=a[i]*10

end;

writeln;

for i:=1 to n do write(a[i]:3,' ')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?