В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Valeria20091
Valeria20091
17.11.2020 17:45 •  Информатика

Добавить перед каждым словом его порядковый номер в предложении. pascal написать программу кто сможет

Ответ:
nikzhukov989
nikzhukov989
21.08.2020 21:19

Pascal ABC

var

 s,news:string;

 k:longint;

begin

 k:=0;

 read(s);

 s:=s+' ';

 while s <> '' do

 begin

   if copy(s,1,pos(' ',s)) = ' ' then

   begin  

     delete(s,1,pos(' ',s));

     news:=news+' ';

   end

   else

   begin

     inc(k);

     news:=news+inttostr(k)+'.'+copy(s,1,pos(' ',s));

     delete(s,1,pos(' ',s));

   end;

 end;

 writeln(news);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?