В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
anja565449
anja565449
23.02.2022 05:10 •  Информатика

50 с решением информатики 1. написать программу которая считает сумму 2ух введённых чисел и выводит результат на экран; 2. дана следующая функция, написать программу которая находит значение функции по переданному х. использовать оператор ветвления if, then, else. результат вывести на экран: дана следующая функция: y = f (x): y = x - 6, если х > 0 y = 32x - 7, если x = 0 y = 5 x - 2, если х < 0 3. написать программу которая инициализирует массив с 50 значениями, начиная с 1 и поэлементно заполняет его. результат вывести на экран. использовать при написании цикл с параметром.

Ответ:
ПолинаКот197
ПолинаКот197
09.10.2020 14:59

1)

var a,b:longint;

begin

readln(a,b);

writeln(a+b);

end.

2)

var x:longint;

begin

readln(x);

if(x>0) then writeln(x-6) else if(x=0) then writeln(32*x-7) else if(x<0) then writeln(5*x-2);

end.

3) В третьей условие не совсем понял, если что, дополни, отредактирую код. Какие значения принимают элементы (по какому принципу заполняется массив)? Написал для массива с элементами от 1 до 50.

var a:array[1..50] of integer;

var i:integer;

begin

for i:=1 to 50 do a[i]:=i;

for i:=1 to 50 do writeln(a[i]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?