В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
keksukYT
keksukYT
13.03.2023 21:14 •  Информатика

Дан символьный массив а[n][n]. найти все такие целые числа k, что k-я строка матрицы совпадает с k-м столбцом. написать программу на с++

Ответ:
rusrusik
rusrusik
09.10.2020 14:36

#include <bits/stdc++.h>

using namespace std;

int a[1010][1010],n;

bool sovp(int x) {

for (int i = 1; i <= n; i++)

 if (a[x][i] != a[i][x]) return 0;

return 1;

}

main () {

cin >>n;

for (int i = 1; i <= n; i++)

 for (int j = 1; j <= n; j++)

  cin >>a[i][j];

for (int i = 1; i <= n; i++)

{

 if (sovp(i) == 1) cout <<i <<" ";

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?