В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
GrechukhinGleb
GrechukhinGleb
25.04.2020 00:33 •  Информатика

Составить программу вычисления, a - сумма положительных элементов массива; b - количество отрицательных элементов массива; c - произведение элементов массива с нечетными номерами. полученные значения элементов а,b,c,w вывести на печать. паскаль!

Ответ:
salome5toriy
salome5toriy
10.09.2020 23:56

const n=10;

var m:array [1..n] of integer;

i,A,B,C:integer;

begin

C:=1;

write('Массив: ');

for i:=1 to n do

begin

m[i]:=random(41)-20;

if m[i] > 0 then A:=A+m[i];

if m[i] < 0 then B:=B+1;

if i mod 2 <> 0 then C:=C*m[i];

write(m[i],'  ')

end;

writeln;

writeln('Сумма положительных элементов: ',A);

writeln('Количество отрицательных элементов: ',B);

writeln('Произведение элементов массива с нечетными номерами: ',C);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?