В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
olyamin0
olyamin0
20.07.2022 14:31 •  Информатика

Нужна ! с операторов div и mod написать программу в паскале. на вход- трехзначное число. на выход- вывести на экран количество сотен, десятков и единиц в этом числе.

Ответ:
sorrypepemain
sorrypepemain
09.10.2020 14:15

Program N1;

var a,c1,c2,c3: integer;

begin

 writeln('Введите число');

 read(a);

 c1:=a mod 10;

 c2:=(a div 10) mod 10;

 c3:=(a div 100) mod 10;

 writeln('Кол-во сотен = ',c3);

 writeln('Кол-во десятков = ',c2);

 writeln('Кол-во единиц = ',c1);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?